Aviso de seguridad de Debian

DSA-759-1 phppgadmin -- olvido de sanear la entrada

Fecha del informe:
18 de jul de 2005
Paquetes afectados:
phppgadmin
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 14142.
En el diccionario CVE de Mitre: CVE-2005-2256.
Información adicional:

Se ha descubierto una vulnerabilidad en phpgadmin, una serie de guiones en PHP para administrar PostgreSQL a través de la WWW, que podían provocar la revelación de información sensible. Para sacar provecho con éxito de esta vulnerabilidad, es necesario que esté desactivado "magic_quotes_gpc".

La distribución estable anterior (woody) no se ve afectada por este problema.

Para la distribución estable (sarge), este problema se ha corregido en la versión 3.5.2-5.

Para la distribución inestable (sid), este problema se ha corregido en la versión 3.5.4.

Le recomendamos que actualice el paquete phpgadmin.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.dsc
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.diff.gz
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.