Bulletin d'alerte Debian

DSA-759-1 phppgadmin -- Mauvaise vérification des entrées

Date du rapport :
18 juillet 2005
Paquets concernés :
phppgadmin
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 14142.
Dans le dictionnaire CVE du Mitre : CVE-2005-2256.
Plus de précisions :

Une vulnérabilité a été découverte dans phppgadmin, un ensemble de scripts PHP pour administrer des bases PostgreSQL par le web, qui peut mener à la divulgation d'informations sensibles. L'exploitation de cette vulnérabilité n'est possible que si l'option « magic_quotes_gpc » est désactivée.

L'ancienne distribution stable (Woody) n'est pas touchée par cette vulnérabilité.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 3.5.2-5.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 3.5.4.

Nous vous recommandons de mettre à jour votre paquet phppgadmin.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.dsc
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.diff.gz
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.