Debian セキュリティ勧告

DSA-759-1 phppgadmin -- 入力のサニタイジング欠落

報告日時:
2005-07-18
影響を受けるパッケージ:
phppgadmin
危険性:
あり
参考セキュリティデータベース:
(SecurityFocus の) Bugtraq データベース: BugTraq ID 14142.
Mitre の CVE 辞書: CVE-2005-2256.
詳細:

ウェブから PostgreSQL を管理する PHP スクリプト群 phppgadmin に脆弱性が発見されました。機密情報の公開につながる可能性があります。 悪用が成功するためには「magic_quotes_gpc」が無効化されている必要があります。

旧安定版 (old stable) ディストリビューション (woody) にはこの問題の影響はありません。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 3.5.2-5 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 3.5.4 で修正されています。

直ちに phppgadmin パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.dsc
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.diff.gz
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。