Debian Security Advisory

DSA-762-1 affix -- several vulnerabilities

Date Reported:
19 Jul 2005
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 318327, Bug 318328.
In the Bugtraq database (at SecurityFocus): BugTraq ID 14230.
In Mitre's CVE dictionary: CVE-2005-2250, CVE-2005-2277.
More information:

Kevin Finisterre discovered two problems in the Bluetooth FTP client from affix, user space utilities for the Affix Bluetooth protocol stack. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities:

  • CAN-2005-2250

    A buffer overflow allows remote attackers to execute arbitrary code via a long filename in an OBEX file share.

  • CAN-2005-2277

    Missing input sanitising before executing shell commands allow an attacker to execute arbitrary commands as root.

The old stable distribution (woody) is not affected by these problems.

For the stable distribution (sarge) these problems have been fixed in version 2.1.1-2.

For the unstable distribution (sid) these problems have been fixed in version 2.1.2-2.

We recommend that you upgrade your affix package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.