Debian Security Advisory

DSA-763-1 zlib -- remote DoS

Date Reported:
20 Jul 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1849.
More information:

Markus Oberhumer discovered a flaw in the way zlib, a library used for file compression and decompression, handles invalid input. This flaw can cause programs which use zlib to crash when opening an invalid file.

This problem does not affect the old stable distribution (woody).

For the current stable distribution (sarge), this problem has been fixed in version 1.2.2-4.sarge.2.

For the unstable distribution (sid), this problem has been fixed in version 1.2.3-1.

We recommend that you upgrade your zlib package.

Fixed in:

Debian GNU/Linux 3.1 (stable)

HP Precision:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.