Debian Security Advisory

DSA-767-1 ekg -- integer overflows

Date Reported:
27 Jul 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1852.
More information:

Marcin Slusarz discovered two integer overflow vulnerabilities in libgadu, a library provided and used by ekg, a console Gadu Gadu client, an instant messaging program, that could lead to the execution of arbitrary code.

The library is also used by other packages such as kopete, which should be restarted to take effect of this update.

The old stable distribution (woody) does not contain an ekg package.

For the stable distribution (sarge) these problems have been fixed in version 1.5+20050411-5.

For the unstable distribution (sid) these problems have been fixed in version 1.5+20050718+1.6rc3-1.

We recommend that you upgrade your ekg package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.