Debian Security Advisory

DSA-772-1 apt-cacher -- missing input sanitising

Date Reported:
03 Aug 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1854.
More information:

Eduard Bloch discovered a bug in apt-cacher, a caching system for Debian package and source files, that could allow remote attackers to execute arbitrary commands on the caching host as user www-data.

The old stable distribution (woody) does not contain this package.

For the stable distribution (sarge) this problem has been fixed in version 0.9.4sarge1.

For the unstable distribution (sid) this problem has been fixed in version 0.9.10.

We recommend that you upgrade your apt-cacher package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.