Debian-Sicherheitsankündigung

DSA-772-1 apt-cacher -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
03. Aug 2005
Betroffene Pakete:
apt-cacher
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2005-1854.
Weitere Informationen:

Eduard Bloch entdeckte einen Fehler in apt-cacher, einem Cache-System für Debians Paket- und Quellendateien, der entfernten Angreifern ermöglicht, auf dem zwischenspeichernden Rechner beliebige Befehle als Benutzer www-data auszuführen.

Die alte Stable-Distribution (Woody) enthält dieses Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.9.4sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.9.10 behoben.

Wir empfehlen Ihnen, Ihr apt-cacher-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/a/apt-cacher/apt-cacher_0.9.4sarge1.dsc
http://security.debian.org/pool/updates/main/a/apt-cacher/apt-cacher_0.9.4sarge1.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/a/apt-cacher/apt-cacher_0.9.4sarge1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.