Debian Security Advisory

DSA-781-1 mozilla-thunderbird -- several vulnerabilities

Date Reported:
23 Aug 2005
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 318728.
In the Bugtraq database (at SecurityFocus): BugTraq ID 14242, BugTraq ID 14242.
In Mitre's CVE dictionary: CVE-2005-0989, CVE-2005-1159, CVE-2005-1160, CVE-2005-1532, CVE-2005-2261, CVE-2005-2265, CVE-2005-2266, CVE-2005-2269, CVE-2005-2270.
More information:

Several problems have been discovered in Mozilla Thunderbird, the standalone mail client of the Mozilla suite. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CAN-2005-0989

    Remote attackers could read portions of heap memory into a Javascript string via the lambda replace method.

  • CAN-2005-1159

    The Javascript interpreter could be tricked to continue execution at the wrong memory address, which may allow attackers to cause a denial of service (application crash) and possibly execute arbitrary code.

  • CAN-2005-1160

    Remote attackers could override certain properties or methods of DOM nodes and gain privileges.

  • CAN-2005-1532

    Remote attackers could override certain properties or methods due to missing proper limitation of Javascript eval and Script objects and gain privileges.

  • CAN-2005-2261

    XML scripts ran even when Javascript disabled.

  • CAN-2005-2265

    Missing input sanitising of InstallVersion.compareTo() can cause the application to crash.

  • CAN-2005-2266

    Remote attackers could steal sensitive information such as cookies and passwords from web sites by accessing data in alien frames.

  • CAN-2005-2269

    Remote attackers could modify certain tag properties of DOM nodes that could lead to the execution of arbitrary script or code.

  • CAN-2005-2270

    The Mozilla browser family does not properly clone base objects, which allows remote attackers to execute arbitrary code.

The old stable distribution (woody) is not affected by these problems since it does not contain Mozilla Thunderbird packages.

For the stable distribution (sarge) these problems have been fixed in version 1.0.2-2.sarge1.0.6.

For the unstable distribution (sid) these problems have been fixed in version 1.0.6-1.

We recommend that you upgrade your Mozilla Thunderbird package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.