Debian Security Advisory

DSA-790-1 phpldapadmin -- programming error

Date Reported:
30 Aug 2005
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 322423.
In Mitre's CVE dictionary: CVE-2005-2654.
More information:

Alexander Gerasiov discovered that phpldapadmin, a web based interface for administering LDAP servers, allows anybody to access the LDAP server anonymously, even if this is disabled in the configuration with the "disable_anon_bind" statement.

The old stable distribution (woody) is not vulnerable to this problem.

For the stable distribution (sarge) this problem has been fixed in version 0.9.5-3sarge2.

For the unstable distribution (sid) this problem has been fixed in version 0.9.6c-5.

We recommend that you upgrade your phpldapadmin package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.