Debian Security Advisory

DSA-794-1 polygen -- programming error

Date Reported:
01 Sep 2005
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 325468.
In Mitre's CVE dictionary: CVE-2005-2656.
More information:

Justin Rye noticed that polygen generates precompiled grammar objects world-writable, which can be exploited by a local attacker to at least fill up the filesystem.

The old stable distribution (woody) does not contain the polygen package.

For the stable distribution (sarge) this problem has been fixed in version 1.0.6-7sarge1.

For the unstable distribution (sid) this problem has been fixed in version 1.0.6-9.

We recommend that you upgrade your polygen package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.