Bulletin d'alerte Debian

DSA-796-1 affix -- Exécution distante de commandes

Date du rapport :
1er septembre 2005
Paquets concernés :
affix
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2005-2716.
Plus de précisions :

Kevin Finisterre a signalé qu'affix, un paquet utilisé pour gérer les sessions Bluetooth sous Linux, utilisait la fonction popen d'une manière non sécurisée. Un attaquant distant pouvait exploiter cette vulnérabilité pour exécuter des commandes arbitraires sur un système vulnérable.

L'ancienne distribution stable (Woody) ne contient pas le paquet affix.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 2.1.1-3.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 2.1.2-3.

Nous vous recommandons de mettre à jour votre paquet affix.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3.diff.gz
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3.dsc
Alpha:
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_alpha.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_alpha.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_amd64.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_amd64.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_arm.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_arm.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_hppa.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_hppa.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_i386.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_i386.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_ia64.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_ia64.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_m68k.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_m68k.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_m68k.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_mips.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_mips.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_mipsel.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_mipsel.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_powerpc.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_powerpc.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_s390.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_s390.deb
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/a/affix/affix_2.1.1-3_sparc.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix-dev_2.1.1-3_sparc.deb
http://security.debian.org/pool/updates/main/a/affix/libaffix2_2.1.1-3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.