Debian Security Advisory

DSA-799-1 webcalendar -- remote code execution

Date Reported:
02 Sep 2005
Affected Packages:
Security database references:
No other external database security references currently available.
More information:

A trivially-exploitable bug was discovered in webcalendar that allows an attacker to execute arbitrary code with the privileges of the HTTP daemon on a system running a vulnerable version.

The old stable distribution (woody) does not contain the webcalendar package.

For the stable distribution (sarge) this problem has been fixed in version 0.9.45-4sarge2.

For the unstable distribution (sid) this problem will be fixed shortly.

We recommend that you upgrade your webcalendar package immediately.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.