Bulletin d'alerte Debian

DSA-806-1 gcvs -- Fichiers temporaires non sécurisés

Date du rapport :
9 septembre 2005
Paquets concernés :
cvs
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 325106.
Dans le dictionnaire CVE du Mitre : CVE-2005-2693.
Plus de précisions :

Marcus Meissner a découvert que le programme cvsbug du paquet gcvs, une interface graphique à CVS (gestionnaire de versions), ne protégeait pas ses fichiers temporaires.

Pour l'ancienne distribution stable (Woody), ce problème a été corrigé dans la version 1.0a7-2woody1.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 1.0final-5sarge1.

Pour la distribution instable (Sid), le paquet gcvs ne contient plus le programme cvsbug.

Nous vous recommandons de mettre à jour votre paquet gcvs.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1.dsc
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1.diff.gz
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0a7-2woody1_sparc.deb

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1.dsc
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1.diff.gz
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/g/gcvs/gcvs_1.0final-5sarge1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.