Debians sikkerhedsbulletin

DSA-830-1 ntlmaps -- forkerte rettigheder

Rapporteret den:
30. sep 2005
Berørte pakker:
ntlmaps
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2005-2962.
Yderligere oplysninger:

Drew Parsons har bemærket at post-installeringsskriptet hørende til ntlmaps, en NTLM-autentificeringsproxyserver, ændrer rettighederne på opsætningsfilen til at være skrivbar for alle. Filen indeholder brugernavn og adgangskode til det Windows NT-system, som ntlmaps forbinder sig til, hvorfor oplysningerne er tilgængelige for lokale brugere.

Den gamle stabile distribution (woody) indeholder ikke pakken ntlmaps.

I den stabile distribution (sarge) er dette problem rettet i version 0.9.9-2sarge1.

I den ustabile distribution (sid) er dette problem rettet i version 0.9.9-4.

Vi anbefaler at du opgraderer din ntlmaps-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/n/ntlmaps/ntlmaps_0.9.9-2sarge1.dsc
http://security.debian.org/pool/updates/main/n/ntlmaps/ntlmaps_0.9.9-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/n/ntlmaps/ntlmaps_0.9.9.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/n/ntlmaps/ntlmaps_0.9.9-2sarge1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.