Debian Security Advisory

DSA-840-1 drupal -- missing input sanitising

Date Reported:
04 Oct 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-2498.
More information:

Stefan Esser of the Hardened-PHP Project reported a serious vulnerability in the third-party XML-RPC library included with some Drupal versions. An attacker could execute arbitrary PHP code on a target site. This update pulls in the latest XML-RPC version from upstream.

The old stable distribution (woody) is not affected by this problem since no drupal is included.

For the stable distribution (sarge) this problem has been fixed in version 4.5.3-4.

For the unstable distribution (sid) this problem has been fixed in version 4.5.5-1.

We recommend that you upgrade your drupal package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.