Debians sikkerhedsbulletin

DSA-867-1 module-assistant -- usikker midlertidig fil

Rapporteret den:
20. okt 2005
Berørte pakker:
module-assistant
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2005-3121.
Yderligere oplysninger:

Eduard Bloch har opdaget at en rule-fil i module-assistant, et værktøj til at gøre det nemmere at oprette modul-pakker, opretter en midlertidig fil på en usikker måde. Den udføres normalt også fra andre pakker.

Den gamle stabile distribution (woody) indeholder ikke en module-assistant-pakke.

I den stabile distribution (sarge) er dette problem rettet i version 0.9sarge1.

I den ustabile distribution (sid) er dette problem rettet i version 0.9.10.

Vi anbefaler at du opgraderer din module-assistant-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1.dsc
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.