Debian-Sicherheitsankündigung

DSA-867-1 module-assistant -- Unsichere temporäre Datei

Datum des Berichts:
20. Okt 2005
Betroffene Pakete:
module-assistant
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2005-3121.
Weitere Informationen:

Eduard Bloch entdeckte, dass eine Datei mit Regeln in module-assistant, einem Werkzeug zur vereinfachten Erstellung von Modulpaketen, auf unsichere Art und Weise eine temporäre Datei erstellt. Diese Datei wird für gewöhnlich auch von anderen Pakete ausgeführt.

Die alte Stable-Distribution (Woody) enthält kein module-assistant-Paket.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 0.9sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.9.10 behoben.

Wir empfehlen Ihnen, Ihr module-assistant-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1.dsc
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/m/module-assistant/module-assistant_0.9sarge1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.