Bulletin d'alerte Debian

DSA-869-1 eric -- Mauvaise vérification des entrées

Date du rapport :
21 octobre 2005
Paquets concernés :
eric
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 330893.
Dans le dictionnaire CVE du Mitre : CVE-2005-3068.
Plus de précisions :

Les développeurs d'eric, un environnement de développement complet pour Python, ont corrigé un bogue dans le traitement des fichiers projet, qui pouvait permettre l'exécution de code arbitraire.

L'ancienne distribution stable (Woody) ne contient pas le paquet eric.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 3.6.2-2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 3.7.2-1.

Nous vous recommandons de mettre à jour votre paquet eric.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/e/eric/eric_3.6.2-2.dsc
http://security.debian.org/pool/updates/main/e/eric/eric_3.6.2-2.diff.gz
http://security.debian.org/pool/updates/main/e/eric/eric_3.6.2.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/e/eric/eric_3.6.2-2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.