Debian セキュリティ勧告

DSA-874-1 lynx -- バッファオーバフロー

報告日時:
2005-10-27
影響を受けるパッケージ:
lynx
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2005-3120.
詳細:

Ulf Härnhammar さんが、テキストモードのウェブブラウザ lynx にバッファオーバフローを発見しました。リモートからの悪用が可能です。NNTP サーバへの接続時のアジア文字の処理で、lynx が誤ってバッファの境界を越えて書き込み、 任意のコードの実行につながる可能性があります。

旧安定版 (old stable) ディストリビューション (woody) では、この問題はバージョン 2.8.4.1b-3.3 で修正されています。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 2.8.5-2sarge1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題は近く修正予定です。

直ちに lynx パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3.dsc
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3.diff.gz
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.4.1b-3.3_sparc.deb

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1.dsc
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lynx/lynx_2.8.5-2sarge1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。