Debian セキュリティ勧告

DSA-877-1 gnump3d -- クロスサイトスクリプティング、ディレクトリトラバーサル

報告日時:
2005-10-28
影響を受けるパッケージ:
gnump3d
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2005-3123, CVE-2005-3424, CVE-2005-3425.
詳細:

Steve Kemp さんが、MP3 および OGG ファイル用のストリーミングサーバ gnump3d に脆弱性を 2 件、発見しました。The Common Vulnerabilities and Exposures project は以下の問題を認識しています:

  • CVE-2005-3122

    404 エラーページが、悪意のある javascript の内容を結果のページにそのまま出力するため、 攻撃対象者のブラウザで実行されることになります。

  • CVE-2005-3123

    特別に細工した URL を使用し、ストリーミングサーバのユーザにアクセス権限のある任意のファイルを読み取ることが可能です。

旧安定版 (old stable) ディストリビューション (woody) には gnump3d パッケージは含まれません。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 2.9.3-1sarge2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.9.6-1 で修正されています。

直ちに gnump3d パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge2.dsc
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3.orig.tar.gz
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge2.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/g/gnump3d/gnump3d_2.9.3-1sarge2_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。