Debian セキュリティ勧告

DSA-891-1 gpsdrive -- フォーマット文字列

報告日時:
2005-11-09
影響を受けるパッケージ:
gpsdrive
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2005-3523.
詳細:

Kevin Finisterre さんが、カーナビゲーションシステム gpsdrive にフォーマット文字列脆弱性を発見しました。 任意のコードの実行につながる可能性があります。

旧安定版 (old stable) ディストリビューション (woody) には gpsdrive パッケージは含まれません。

安定版 (stable) ディストリビューション (sarge) では、この問題はバージョン 2.09-2sarge1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.09-2sarge1 で修正されています。

直ちに gpsdrive パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1.dsc
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/g/gpsdrive/gpsdrive_2.09-2sarge1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。