Debian-Sicherheitsankündigung

DSA-907-1 ipmenu -- Unsichere temporäre Datei

Datum des Berichts:
23. Nov 2005
Betroffene Pakete:
ipmenu
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 244709.
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 10269.
In Mitres CVE-Verzeichnis: CVE-2004-2569.
Weitere Informationen:

Akira Yoshiyama bemerkte, dass ipmenu, eine grafische Benutzeroberfläche für cursel iptables/iproute2, eine temporäre Datei in unsicherer Weise erstellt. Dadurch wird es einem lokalen Angreifer ermöglicht, beliebige Dateien mittels Symlink-Angriff zu überschreiben.

Für die alte Stable-Distribution (Woody) wurde dieses Problem in version 0.0.3-4woody1

Die Stable-Distribution (Sarge) enthält das ipmenu-Paket nicht.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.0.3-5 behoben.

Wir empfehlen Ihnen, Ihr ipmenu-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/i/ipmenu/ipmenu_0.0.3-4woody1.dsc
http://security.debian.org/pool/updates/main/i/ipmenu/ipmenu_0.0.3-4woody1.diff.gz
http://security.debian.org/pool/updates/main/i/ipmenu/ipmenu_0.0.3.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/i/ipmenu/ipmenu_0.0.3-4woody1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.