Debian Security Advisory

DSA-915-1 helix-player -- buffer overflow

Date Reported:
02 Dec 2005
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 15381.
In Mitre's CVE dictionary: CVE-2005-2629.
More information:

An integer overflow has been discovered in helix-player, the helix audio and video player. This flaw could allow a remote attacker to run arbitrary code on a victims computer by supplying a specially crafted network resource.

The old stable distribution (woody) does not contain a helix-player package.

For the stable distribution (sarge) these problems have been fixed in version 1.0.4-1sarge2.

For the unstable distribution (sid) these problems have been fixed in version 1.0.6-1.

We recommend that you upgrade your helix-player package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Intel IA-32:

MD5 checksums of the listed files are available in the original advisory.