Bulletin d'alerte Debian

DSA-923-1 dropbear -- Dépassement de tampon

Date du rapport :
19 décembre 2005
Paquets concernés :
dropbear
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2005-4178.
Plus de précisions :

Un dépassement de tampon a été découvert dans dropbear, un ensemble léger client et serveur SSH2, qui pouvait permettre à des utilisateurs authentifiés d'exécuter du code arbitraire avec les mêmes droits que le serveur, typiquement ceux du superutilisateur.

L'ancienne distribution stable (Woody) ne contient pas dropbear.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 0.45-2sarge0.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.47-1.

Nous vous recommandons de mettre à jour votre paquet dropbear.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0.dsc
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0.diff.gz
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/d/dropbear/dropbear_0.45-2sarge0_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.