Säkerhetsbulletin från Debian

DSA-925-1 phpbb2 -- flera sårbarheter

Rapporterat den:
2005-12-22
Berörda paket:
phpbb2
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 35662, Fel 336582, Fel 336587.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 15170, BugTraq-id 15243.
I Mitres CVE-förteckning: CVE-2005-3310, CVE-2005-3415, CVE-2005-3416, CVE-2005-3417, CVE-2005-3418, CVE-2005-3419, CVE-2005-3420, CVE-2005-3536, CVE-2005-3537.
Ytterligare information:

Flera sårbarheter har upptäckts i phpBB, en webbforumprogramvara. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2005-3310

    Flera tolkningsfel gjorde det möjligt för autentiserade användare utifrån att injicera godtyckliga webbskript när avatarer från andra servrar eller insändning av avatarer har aktiverats.

  • CVE-2005-3415

    phpBB gjorde det möjligt för angripare utifrån att gå runt skyddsmekanismer som avregistrerar globala variabler, vilket gör det möjligt för angripare att manipulera phpBB:s beteende.

  • CVE-2005-3416

    phpBB gjorde det möjligt för angripare utifrån att gå runt säkerhetskontroller när register_globals aktiverats och session_start-funktionen inte har anropats för att hantera en session.

  • CVE-2005-3417

    phpBB gjorde det möjligt för angripare utifrån att modifiera globala variabler och gå runt säkerhetsmekanismer.

  • CVE-2005-3418

    Flera serveröverskridande skriptsårbarheter (XSS) gjorde det möjligt för angripare utifrån att injicera godtyckliga webbskript.

  • CVE-2005-3419

    En SQL-injiceringssårbarhet gjorde det möjligt för angripare utifrån att exekvera godtyckliga SQL-kommandon.

  • CVE-2005-3420

    phpBB gjorde det möjligt för angripare utifrån att ändra reguljära uttryck och exekvera PHP-kod via signature_bbcode_uid-flaggan.

  • CVE-2005-3536

    Saknad städning av indata i ärendetypen gjorde det möjligt för angripare utifrån att injicera godtyckliga SQL-kommandon.

  • CVE-2005-3537

    Saknad anropsvalidering tillät angripare utifrån att redigera privata meddelanden hos andra användare.

Den gamla stabila utgåvan (Woody) innehåller inte phpbb2-paket.

För den stabila utgåvan (Sarge) har dessa problem rättats i version 2.0.13+1-6sarge2.

För den instabila utgåvan (Sid) har dessa problem rättats i version 2.0.18-1.

Vi rekommenderar att ni uppgraderar era phpbb2-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1-6sarge2.dsc
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1-6sarge2.diff.gz
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13+1.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-conf-mysql_2.0.13-6sarge2_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2-languages_2.0.13-6sarge2_all.deb
http://security.debian.org/pool/updates/main/p/phpbb2/phpbb2_2.0.13-6sarge2_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.