Debian-Sicherheitsankündigung

DSA-927-2 tkdiff -- Unsichere temporäre Datei

Datum des Berichts:
27. Dez 2005
Betroffene Pakete:
tkdiff
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2005-3343.
Weitere Informationen:

Die letzte Aktualisierung von tkdiff enthielt einen Programmierfehler, der von dieser Version behoben wird. Der Vollständigkeit halber ist unten der Text des ursprünglichen Gutachtens wiedergegeben:

Javier Fernández-Sanguino Peña vom Debian-Sicherheits-Audit-Projekt entdeckte, dass tkdiff, ein grafisches diff-Werkzeug mit Gegenüberstellung der Unterschiede, temporäre Dateien auf unsichere Art erstellt.

Für die alte Stable-Distribution (Woody) wurde dieses Problem in Version 3.08-3woody1 behoben.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 4.0.2-1sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 4.0.2-4 behoben.

Wir empfehlen Ihnen, Ihr tkdiff-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody1.dsc
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody0.diff.gz
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody1_all.deb

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1.dsc
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.

MD5-Prüfsummen der aufgezählten Dateien stehen in der überarbeiteten Sicherheitsankündigung zur Verfügung.