Alerta de Segurança Debian

DSA-927-2 tkdiff -- arquivos temporários inseguros

Data do Alerta:
27 Dez 2005
Pacotes Afetados:
tkdiff
Vulnerável:
Sim
Referência à base de dados de segurança:
No dicionário CVE do Mitre: CVE-2005-3343.
Informações adicionais:

A última atualização do tkdiff contém um erro de programação que é corrigido nesta versão. Para deixar completo, nós adicionamos o texto de aviso original:

Javier Fernández-Sanguino Peña do Projeto de Auditoria de Segurança do Debian ("Debian Security Audit Project") descobriu que o tkdiff, um utilitário "diff" lado-a-lado, cria arquivos temporários de uma forma insegura.

Para a antiga distribuição estável ("woody") este problema foi corrigido na versão 3.08-3woody1.

Para a distribuição estável ("sarge") este problema foi corrigido na versão 4.0.2-1sarge1.

Para a distribuição instável ("sid") este problema foi corrigido na versão 4.0.2-4.

Recomendamos que você atualize seu pacote tkdiff.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody1.dsc
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody0.diff.gz
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08.orig.tar.gz
Componente independente de arquitetura:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_3.08-3woody1_all.deb

Debian GNU/Linux 3.1 (sarge)

Fonte:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1.dsc
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2.orig.tar.gz
Componente independente de arquitetura:
http://security.debian.org/pool/updates/main/t/tkdiff/tkdiff_4.0.2-1sarge1_all.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.

Checksums MD5 dos arquivos listados estão disponíveis no alerta revisado.