Debian-Sicherheitsankündigung

DSA-1014-1 firebird2 -- Pufferüberlauf

Datum des Berichts:
23. Mär 2006
Betroffene Pakete:
firebird2
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 357580.
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 10446.
In Mitres CVE-Verzeichnis: CVE-2004-2043.
Weitere Informationen:

Aviram Jenik und Damyan Ivanov entdeckten einen Pufferüberlauf in firebird2, einem auf InterBase 6.0 Code basierendem RDBMS, der es entfernten Angreifern erlaubt, einen Absturz herbeizuführen.

Die alte Stable-Distribution (Woody) enthält das firebird2-Paket nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 1.5.1-4sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 1.5.3.4870-3

Wir empfehlen Ihnen, Ihre firebird2-Pakete zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.dsc
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.diff.gz
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-classic-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-dev_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-examples_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-server-common_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-super-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-super_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-super_1.5.1-4sarge1_i386.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.