Aviso de seguridad de Debian

DSA-1014-1 firebird2 -- desbordamiento de buffer

Fecha del informe:
23 de mar de 2006
Paquetes afectados:
firebird2
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 357580.
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 10446.
En el diccionario CVE de Mitre: CVE-2004-2043.
Información adicional:

Aviram Jenik y Damyan Ivanov descubrieron un desbordamiento de buffer en firebird2, un sistema gestor de bases de datos relacionales basado en el código de InterBase 6.0, que permitía que los atacantes remotos lo hiciesen caer.

La distribución estable anterior (woody) no contiene los paquetes de firebird2.

Para la distribución estable (sarge), este problema se ha corregido en la versión 1.5.1-4sarge1.

Para la distribución inestable (sid), este problema se ha corregido en la versión 1.5.3.4870-3

Le recomendamos que actualice los paquetes de firebird2.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.dsc
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.diff.gz
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-classic-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-dev_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-examples_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-server-common_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-super-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-super_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-super_1.5.1-4sarge1_i386.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.