Bulletin d'alerte Debian

DSA-1014-1 firebird2 -- Dépassement de tampon

Date du rapport :
23 mars 2006
Paquets concernés :
firebird2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 357580.
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 10446.
Dans le dictionnaire CVE du Mitre : CVE-2004-2043.
Plus de précisions :

Aviram Jenik et Damyan Ivanov ont découvert un dépassement de tampon dans firebird2, une base de données relationelle basée sur le code d'InterBase 6.0, qui permettait à des attaquants distants de provoquer un plantage.

L'ancienne distribution stable (Woody) ne contient pas les paquets firebird2.

Pour l'actuelle distribution stable (Sarge), ce problème a été corrigé dans la version 1.5.1-4sarge1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.5.3.4870-3

Nous vous recommandons de mettre à jour vos paquets firebird2.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.dsc
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1-4sarge1.diff.gz
http://security.debian.org/pool/updates/main/f/firebird2/firebird2_1.5.1.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-classic-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-dev_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-examples_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-server-common_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-super-server_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/firebird2-utils-super_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-classic_1.5.1-4sarge1_i386.deb
http://security.debian.org/pool/updates/main/f/firebird2/libfirebird2-super_1.5.1-4sarge1_i386.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.