Aviso de seguridad de Debian

DSA-1026-1 sash -- desbordamientos de buffer

Fecha del informe:
6 de abr de 2006
Paquetes afectados:
sash
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 318069.
En el diccionario CVE de Mitre: CVE-2005-1849, CVE-2005-2096.
Información adicional:

Markus Oberhumer descubrió una debilidad en la forma de gestionar las entradas no válidas en zlib, una biblioteca que se utiliza para comprimir y descomprimir archivos. Esta debilidad podía provocar que cayesen los programas que utilizasen zlib al abrir un archivo no válido. Otro error más en la forma de gestionar la regeneración de ciertos archivos comprimidos en zlib podía provocar que un programa que utilizase zlib cayese al abrir un archivo no válido.

sash, el shell autónomo, enlaza estáticamente con zlib y, por tanto, se ve afectado por estos problemas.

La distribución estable anterior (woody) no se ve afectada por estos problemas.

Para la distribución estable (sarge), estos problemas se han corregido en la versión 3.7-5sarge1.

Para la distribución inestable (sid), estos problemas se han corregido en la versión 3.7-6.

Le recomendamos que actualice el paquete sash.

Arreglado en:

Debian GNU/Linux 3.1 (sarge)

Fuentes:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1.dsc
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1.diff.gz
http://security.debian.org/pool/updates/main/s/sash/sash_3.7.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/sash/sash_3.7-5sarge1_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.