Debian Security Advisory

DSA-1029-1 libphp-adodb -- several vulnerabilities

Date Reported:
08 Apr 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 349985, Bug 358872.
In the Bugtraq database (at SecurityFocus): BugTraq ID 16187, BugTraq ID 16364, BugTraq ID 16720.
In Mitre's CVE dictionary: CVE-2006-0146, CVE-2006-0147, CVE-2006-0410, CVE-2006-0806.
More information:

Several vulnerabilities have been discovered in libphp-adodb, the 'adodb' database abstraction layer for PHP. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2006-0146

    Andreas Sandblad discovered that improper user input sanitisation results in a potential remote SQL injection vulnerability enabling an attacker to compromise applications, access or modify data, or exploit vulnerabilities in the underlying database implementation. This requires the MySQL root password to be empty. It is fixed by limiting access to the script in question.

  • CVE-2006-0147

    A dynamic code evaluation vulnerability allows remote attackers to execute arbitrary PHP functions via the 'do' parameter.

  • CVE-2006-0410

    Andy Staudacher discovered an SQL injection vulnerability due to insufficient input sanitising that allows remote attackers to execute arbitrary SQL commands.

  • CVE-2006-0806

    GulfTech Security Research discovered multiple cross-site scripting vulnerabilities due to improper user-supplied input sanitisation. Attackers can exploit these vulnerabilities to cause arbitrary scripts to be executed in the browser of an unsuspecting user's machine, or result in the theft of cookie-based authentication credentials.

For the old stable distribution (woody) these problems have been fixed in version 1.51-1.2.

For the stable distribution (sarge) these problems have been fixed in version 4.52-1sarge1.

For the unstable distribution (sid) these problems have been fixed in version 4.72-0.1.

We recommend that you upgrade your libphp-adodb package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.