Debian-Sicherheitsankündigung

DSA-1032-1 zope-cmfplone -- Programmierfehler

Datum des Berichts:
12. Apr 2006
Betroffene Pakete:
zope-cmfplone
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2006-1711.
Weitere Informationen:

Es wurde entdeckt, dass das Content-Management-System Plone Sicherheitsdeklarationen für drei interne Klassen vermissen lässt. Dies erlaubt eine Manipulation von Benutzerportraits durch nichtprivilegierte Benutzer.

Die alte Stable-Distribution (Woody) enthält Plone nicht.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 2.0.4-3sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.1.2-2 behoben.

Wir empfehlen Ihnen, Ihr zope-cmfplone-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/z/zope-cmfplone/zope-cmfplone_2.0.4-3sarge1.dsc
http://security.debian.org/pool/updates/main/z/zope-cmfplone/zope-cmfplone_2.0.4-3sarge1.diff.gz
http://security.debian.org/pool/updates/main/z/zope-cmfplone/zope-cmfplone_2.0.4.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/z/zope-cmfplone/plone_2.0.4-3sarge1_all.deb
http://security.debian.org/pool/updates/main/z/zope-cmfplone/zope-cmfplone_2.0.4-3sarge1_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.