Debians sikkerhedsbulletin

DSA-1033-1 horde3 -- flere sårbarheder

Rapporteret den:
12. apr 2006
Berørte pakker:
horde3
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 361967.
I Mitres CVE-ordbog: CVE-2005-4190, CVE-2006-1260, CVE-2006-1491.
Yderligere oplysninger:

Flere fjernudnytbare sårbarheder er opdaget i webprogramsskelettet Horde, hvilket kunne føre til udførelse af vilkårlig webskriptkode. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2005-4190

    Flere sårbarhed der kunne udnyttes på tværs af websteder (cross-site scriping) er opdaget i "share edit window".

  • CVE-2006-1260

    Null-tegn i URL-paramentre omgik fornuftskontroller, hvilket gjorde det muligt for fjernangribere at læse vilkårlig filer, hvilket muliggjorde informationsafsløring.

  • CVE-2006-1491

    Brugerinddata i hjælpeviseren blev sendt ukontrolleret videre til funktionen eval(), hvilket gjorde det muligt at indsprøjte vilkårlig webkode.

Den gamle stabile distribution (woody) indeholder ikke horde3-pakker.

I den stabile distribution (sarge) er disse problemer rettet i version 3.0.4-4sarge3.

I den ustabile distribution (sid) er disse problemer rettet i version 3.1.1-1.

Vi anbefaler at du opgraderer din horde3-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3.dsc
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3.diff.gz
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.