Säkerhetsbulletin från Debian

DSA-1033-1 horde3 -- flera sårbarheter

Rapporterat den:
2006-04-12
Berörda paket:
horde3
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 361967.
I Mitres CVE-förteckning: CVE-2005-4190, CVE-2006-1260, CVE-2006-1491.
Ytterligare information:

Flera utifrån nåbara sårbarheter har upptäckts i webbprogramramverket Horde, vilka kunde leda till exekvering av godtycklig webbskriptkod. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2005-4190

    Flera serveröverskridande skriptsårbarheter har upptäckts i ”share edit-fönstret”.

  • CVE-2006-1260

    Null-tecken i URL-parametern gick förbi ett säkerhetstest, vilket gjorde det möjligt för angripare utifrån att läsa godtyckliga filer, vilket kunde leda till att information läcktes.

  • CVE-2006-1491

    Indata från användaren i hjälpvisaren sändes utan att städas till eval()-funktionen, vilket möjliggjorde injicering av godtycklig webbkod.

Den gamla stabila utgåvan (Woody) innehåller inte horde3-paket.

För den stabila utgåvan (Sarge) har dessa problem rättats i version 3.0.4-4sarge3.

För den instabila utgåvan (Sid) har dessa problem rättats i version 3.1.1-1.

Vi rekommenderar att ni uppgraderar ert horde3-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3.dsc
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3.diff.gz
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.0.4-4sarge3_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.