Debian Security Advisory

DSA-1034-1 horde2 -- several vulnerabilities

Date Reported:
14 Apr 2006
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2006-1260, CVE-2006-1491.
More information:

Several remote vulnerabilities have been discovered in the Horde web application framework, which may lead to the execution of arbitrary web script code. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2006-1260

    Null characters in the URL parameter bypass a sanity check, which allowed remote attackers to read arbitrary files, which allowed information disclosure.

  • CVE-2006-1491

    User input in the help viewer was passed unsanitised to the eval() function, which allowed injection of arbitrary web code.

The old stable distribution (woody) doesn't contain horde2 packages.

For the stable distribution (sarge) these problems have been fixed in version 2.2.8-1sarge2.

The unstable distribution (sid) does no longer contain horde2 packages.

We recommend that you upgrade your horde2 package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.