Debians sikkerhedsbulletin

DSA-1057-1 phpldapadmin -- manglende kontrol af inddata

Rapporteret den:
15. maj 2006
Berørte pakker:
phpldapadmin
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 365313.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 17643.
I Mitres CVE-ordbog: CVE-2006-2016.
Yderligere oplysninger:

Flere sårbarheder i forbindelse med udførelse af skripter på tværs af websteder er opdaget i phpLDAPadmin, en webbaseret grænseflade til administrering af LDAP-servere, hvilket gjorde det muligt for fjernangribere at indsprøjte vilkårlige webskripter eller HTML.

Den gamle stabile distribution (woody) indeholder ikke phpldapadmin-pakker.

I den stabile distribution (sarge) er disse problemer rettet i version 0.9.5-3sarge3.

I den ustabile distribution (sid) er disse problemer rettet i version 0.9.8.3-1.

Vi anbefaler at du opgraderer din phpldapadmin-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.dsc
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.diff.gz
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.