Bulletin d'alerte Debian

DSA-1057-1 phpldapadmin -- Mauvaise vérification des entrées

Date du rapport :
15 mai 2006
Paquets concernés :
phpldapadmin
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 365313.
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 17643.
Dans le dictionnaire CVE du Mitre : CVE-2006-2016.
Plus de précisions :

Plusieurs vulnérabilités de script intersites ont été découvertes dans phpLDAPadmin, une interface web d'administration de serveurs LDAP, qui permettaient à des attaquants distants d'injecter des scripts web ou HTML arbitraires.

L'ancienne distribution stable (Woody) ne contient pas le paquet phpldapadmin.

Pour l'actuelle distribution stable (Sarge), ces problèmes ont été corrigés dans la version 0.9.5-3sarge3.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 0.9.8.3-1.

Nous vous recommandons de mettre à jour votre paquet phpldapadmin.

Corrigé dans :

Debian GNU/Linux 3.1 (sarge)

Source :
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.dsc
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.diff.gz
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.