Säkerhetsbulletin från Debian

DSA-1057-1 phpldapadmin -- städar inte indata

Rapporterat den:
2006-05-15
Berörda paket:
phpldapadmin
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 365313.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 17643.
I Mitres CVE-förteckning: CVE-2006-2016.
Ytterligare information:

Flera serveröverskridande skriptsårbarheter har upptäckts i phpLDAPadmin, ett webbaserat gränssnitt för att administrera LDAP-servrar, vilket gjorde det möjligt för angripare utifrån att injicera godtyckliga webbskript eller HTML.

Den gamla stabila utgåvan (Woody) innehåller inte phpldapadmin-paket.

För den stabila utgåvan (Sarge) har dessa problem rättats i version 0.9.5-3sarge3.

För den instabila utgåvan (Sid) har dessa problem rättats i version 0.9.8.3-1.

Vi rekommenderar att ni uppgraderar ert phpldapadmin-paket.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.dsc
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3.diff.gz
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/phpldapadmin/phpldapadmin_0.9.5-3sarge3_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.