Debian-Sicherheitsankündigung

DSA-1058-1 awstats -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
18. Mai 2006
Betroffene Pakete:
awstats
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 364443, Fehler 365909.
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 17844.
In Mitres CVE-Verzeichnis: CVE-2006-2237.
Weitere Informationen:

Hendrik Weimer entdeckte, dass speziell angefertigte Web-Anfragen zur Folge haben können, dass awstats, ein mächtiges und fähigkeitenreiches Analyseprogramm für Webserver-Protokolldateien, beliebige Befehle ausführt.

Die alte Stable-Distribution (Woody) ist von diesem Problem nicht betroffen.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 6.4-1sarge2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 6.5-2 behoben.

Wir empfehlen Ihnen, Ihr awstats-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge2.dsc
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge2.diff.gz
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/a/awstats/awstats_6.4-1sarge2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.