Debians sikkerhedsbulletin

DSA-1059-1 quagga -- flere sårbarheder

Rapporteret den:
19. maj 2006
Berørte pakker:
quagga
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 365940, Fejl 366980.
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 17808.
I Mitres CVE-ordbog: CVE-2006-2223, CVE-2006-2224, CVE-2006-2276.
Yderligere oplysninger:

Konstantin Gavrilenko har opdaget flere sårbarheder i quagga, BGP/OSPF/RIP-routingdæmonen. Projektet Common Vulnerabilities and Exposures har fundet frem til følgende problemer:

  • CVE-2006-2223

    Fjernangribere kunne få fat i følsomme oplysninger via RIPv1 REQUEST-pakker, også selvom quagga var opsat til at anvende MD5-autentificering.

  • CVE-2006-2224

    Fjernangribere kunne indsprøjte vilkårlige ruter ved hjælp af RIPv1 RESPONSE-pakker, også selvom quagga var opsat til at anvende MD5-autentification.

  • CVE-2006-2276

    Fredrik Widell har opdaget at lokale brugere kunne forårsage et lammelsesangreb (denial of service) i en bestemt sh ip bgp-kommando angivet via telnet.

Den gamle stabile distribution (woody) indeholder ikke pakker quagga-pakker.

I den stabile distribution (sarge) er disse problemer rettet i version 0.98.3-7.2.

I den ustabile distribution (sid) er disse problemer rettet i version 0.99.4-1.

Vi anbefaler at du opgraderer din quagga-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2.dsc
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2.diff.gz
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/q/quagga/quagga-doc_0.98.3-7.2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.