Debian Security Advisory

DSA-1060-1 kernel-patch-vserver -- programming error

Date Reported:
19 May 2006
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2006-2110.
More information:

Jan Rekorajski discovered that the kernel patch for virtual private servers does not limit context capabilities to the root user within the virtual server, which might lead to privilege escalation for some virtual server specific operations.

The old stable distribution (woody) does not contain kernel-patch-vserver packages.

For the stable distribution (sarge) this problem has been fixed in version

For the unstable distribution (sid) this problem has been fixed in version 2.0.1-4.

We recommend that you upgrade your kernel-patch-vserver package and rebuild your kernel immediately.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.