Debians sikkerhedsbulletin

DSA-1060-1 kernel-patch-vserver -- programmeringsfejl

Rapporteret den:
19. maj 2006
Berørte pakker:
kernel-patch-vserver
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2006-2110.
Yderligere oplysninger:

Jan Rekorajski har opdaget at kerne-rettelsen til virtuelle private netværk ikke begrænser kontekstmulighederne til brugeren root på det virtuelle server, hvilket kunne føre til rettighedsforøgelse ved nogle virtuel server-specifikke handlinger.

Den gamle stabile distribution (woody) indeholder ikke kernel-patch-vserver-pakker.

I den stabile distribution (sarge) er dette problem rettet i version 1.9.5.6.

I den ustabile distribution (sid) er dette problem rettet i version 2.0.1-4.

Vi anbefaler at du opgraderer din kernel-patch-vserver-pakke og omgående genopbygger din kerne.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.dsc
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.