Säkerhetsbulletin från Debian

DSA-1060-1 kernel-patch-vserver -- programmeringsfel

Rapporterat den:
2006-05-19
Berörda paket:
kernel-patch-vserver
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2006-2110.
Ytterligare information:

Jan Rekorajski upptäckte att kärnpatchen för virtuella privata servrar inte begränsade kontextkapabiliteter till rootanvändaren inuti den virtuella servern, vilket kunde leda till utökning av privilegier för vissa specifika operationer i den virtuella servern.

Den gamla stabila utgåvan (Woody) innehåller inte paketet kernel-patch-vserver.

För den stabila utgåvan (Sarge) har detta problem rättats i version 1.9.5.6.

För den instabila utgåvan (Sid) har detta problem rättats i version 2.0.1-4.

Vi rekommenderar att ni uppgraderar ert kernel-patch-vserver-paket och bygger om din kärna omedelbart.

Rättat i:

Debian GNU/Linux 3.1 (sarge)

Källkod:
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.dsc
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.