Debians sikkerhedsbulletin

DSA-1061-1 popfile -- manglende kontrol af inddata

Rapporteret den:
19. maj 2006
Berørte pakker:
popfile
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 354464.
I Mitres CVE-ordbog: CVE-2006-0876.
Yderligere oplysninger:

Man har opdaget at popfile, et program til bayesisk mailklassificering, kunne tvinges til at gå ned ved hjælp af misdannede tegnsæt i e-mail-beskeden, hvilket muliggjorde et lammelsesangreb (denial of service).

Den gamle stabile distribution (woody) indeholder ikke popfile-pakker.

I den stabile distribution (sarge) er dette problem rettet i version 0.22.2-2sarge1.

I den ustabile distribution (sid) er dette problem rettet i version 0.22.4-1.

Vi anbefaler at du opgraderer din popfile-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1.dsc
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/popfile/popfile_0.22.2-2sarge1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.