Debian-Sicherheitsankündigung

DSA-1062-1 kphone -- Unsichere Dateierstellung

Datum des Berichts:
19. Mai 2006
Betroffene Pakete:
kphone
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 337830.
In Mitres CVE-Verzeichnis: CVE-2006-2442.
Weitere Informationen:

Sven Dreyer entdeckte, dass KPhone, ein Voice-over-IP-Klient für KDE, eine Konfigurationsdatei für alle lesbar erstellt, wodurch sensitive Informationen wie SIP-Passwörter aufgedeckt werden können.

Die alte Stable-Distribution (Woody) enthält keine kphone-Pakete.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 4.1.0-2sarge1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 4.2-6 behoben.

Wir empfehlen Ihnen, Ihr kphone-Paket zu aktualisieren. Falls Ihre aktuelle kphonerc zu lockere Berechtigungen aufweist, müssen Sie sie von Hand zurücksetzen.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1.dsc
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1.diff.gz
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/k/kphone/kphone_4.1.0-2sarge1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.