Debian Security Advisory

DSA-1066-1 phpbb2 -- missing input sanitising

Date Reported:
20 May 2006
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 365533.
In Mitre's CVE dictionary: CVE-2006-1896.
More information:

It was discovered that phpbb2, a web based bulletin board, does insufficiently sanitise values passed to the "Font Colour 3" setting, which might lead to the execution of injected code by admin users.

The old stable distribution (woody) does not contain phpbb2 packages.

For the stable distribution (sarge) this problem has been fixed in version 2.0.13+1-6sarge3.

For the unstable distribution (sid) this problem will be fixed soon.

We recommend that you upgrade your phpbb2 package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.