Bulletin d'alerte Debian

DSA-1077-1 lynx-ssl -- Erreur de programmation

Date du rapport :
26 mai 2006
Paquets concernés :
lynx-ssl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 296340.
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 11443.
Dans le dictionnaire CVE du Mitre : CVE-2004-1617.
Plus de précisions :

Michal Zalewski a découvert que lynx, un navigateur web en mode texte, ne traitait pas correctement le code HTML contenant une balise TEXTAREA avec une valeur COLS importante et une balise au nom trop long et sans marqueur de fin, ce qui le rendait vulnérable à une attaque par déni de service. Le même code est présent dans lynx-ssl.

Pour l'ancienne distribution stable (Woody), ce problème a été corrigé dans la version 2.8.4.1b-3.3.

L'actuelle distribution stable (Sarge) ne contient plus le paquet lynx-ssl.

La distribution instable (Sid) ne contient plus le paquet lynx-ssl.

Nous vous recommandons de mettre à jour votre paquet lynx-ssl.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3.dsc
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3.diff.gz
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lynx-ssl/lynx-ssl_2.8.4.1b-3.3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.