Debian セキュリティ勧告

DSA-1093-1 xine -- フォーマット文字列脆弱性

報告日時:
2006-06-08
影響を受けるパッケージ:
xine-ui
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2006-2230.
詳細:

xine ビデオプレイヤーのユーザインターフェース xine-ui に複数のフォーマット文字列脆弱性が発見されました。 これらの欠陥を攻撃することでサービス不能 (DoS) 攻撃を引き起こすことができます。

前安定版ディストリビューション (oldstable、コードネーム woody) は、これらの問題の影響を受けません。

安定版ディストリビューション (stable、コードネーム sarge) では、これらの問題はバージョン 0.99.3-1sarge1 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、これらの問題は近く修正される予定です。

xine-ui パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.1 (sarge)

ソース:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1.dsc
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1.diff.gz
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xine-ui/xine-ui_0.99.3-1sarge1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。